Error: Your identity is older than this version of Outlook

DO NOT DOWNLOAD Service Pack 2 (SP2) 14.2.0. This update contains problems that were fixed in 14.2.1. You can go directly from 14.1.0 or higher to 14.2.1. SKIP the 14.2.0 updater. [Added May 3, 2012]

If you get the following error “Your identity is older than this version of Outlook” you will need to revert to Office 2011 v14.1.4 in order to repair your identity.

If you want to remove Office 2011 v 14.2.0 . . .

Continue Reading: Error: Your identity is older than this version of Outlook