Leopard update breaks Entourage support for Exchange SSL root certificates

Apple released Mac OS X 10.5 (Leopard) a week ago and for the most part Entourage 2004 is “very compatible” according to There’s a new cat in town on Microsoft’s Mac Mojo blog. However, they also acknowledge that they discovered some code in their Leopard testing and will be releasing an update “shortly”.

Most of the Entourage trouble reports that I’ve read in the Apple and Microsoft online forums are anecdotal but one Exchange bug . . .

Continue Reading: Leopard update breaks Entourage support for Exchange SSL root certificates