Troubleshooting Office for Mac with Snow Leopard

“Since installing 10.6, I have not been able to get any Microsoft Office 2008 program to run. All Office applications hang on “Optimizing Font Menu Performance.”

Regardless of which method (upgrade or clean install) you used to install Snow Leopard, we’re going to discuss options to troubleshoot and steps to identify the problem so you can get your Office for Mac install working under Snow Leopard.

Fonts seem to be the most common cause of problems using Office 2008 and Office 2004 with Snow Leopard. Deleting font caches BEFORE you update to Snow Leopard is advised since many of the utilities are not working in Snow Leopard yet. I suggest you delete all the older Microsoft fonts replaced by the newer ones installed by Snow Leopard. If you use a lot of custom fonts read this thread on Apple Discussions for more details.

Before you start troubleshooting,

  • Restart your computer at least twice. This has fixed many issues for some users.
  • Verify that you are running the latest version of Office.
    • Office for Mac 2008: 12.2.6*
    • Office for Mac 2008 EWS: 13.0.6*/li>
    • Office for Mac 2004: 11.6.0
    • Office for Mac X: 10.1.9

* Updated for latest versions Sept 2010. For the latest updaters see this page


Simple troubleshooting steps

  1. Create a new User
    1. Go to System Preferences > Accounts
    2. Add a new User account and make it an admin account
    3. Switch to the New User by logging out/in or use Fast User Switching
    4. Test Office in the new User
  2. If the issue is limited to your regular User account try starting up Safe Mode.When booting into safe mode it forces your computer to run various maintenance tasks.
    1. Boot into safe mode using the Shift key. Then, reboot again. (These are some of the items disabled on safe boot:)
      • Disables all fonts other than those in /System/Library/Fonts
      • It moves to the Trash all font caches normally stored in /Library/Caches/com.apple.ATS/(uid)/
      • Disables all startup items and login items
    2. Re-install the problem application. I found this worked for several of my applications.
    3. Restart and restart again! I had everything working correctly, then after sleep nothing worked. Restarting fixed it.
    4. Check your applications for Snow Leopard compatibility.
  3. If the issues exists in the new User and you have verified that you are running a Snow Leopard ready application, then you have problems with your Snow Leopard install.
    1. First check that it’s not hardware related by disconnecting any peripheral devices (be sure to unmount drives before disconnecting).
    2. Run Repair Permissions from Disk Utility.
    3. Log into your problem account go to Users/yourname/Library/Preferences/*com.apple.systemuiserver.plist* and delete this file. Log out and back in. See note 1
    4. Some users reported that doing a re-install of Snow Leopard worked. It appears that the Snow Leopard installer will work like a combo updater and install over the same version.
    5. Resetting the PRAM memory (CMD+ALT+P+R keys together at start up for Three Bongs) and resetting the SMC/PMU on Laptops . Some newer iMacs reset PRAM by disconnecting power for at least 10 minutes.
  4. If it works in Safe Mode but not in normal mode…

    1) Remove Login Items. Open System Preferences > Accounts. Click on the Login Items tab. Remove items. You’ll have to test to see which one (s) is the culprit. Verify that you are running the latest updates for all applications. Some might not be Snow Leopard ready.
    2) Check your Fonts. There appears to be a widespread issue with FontBook and font substitution in 10.6. Something having to do with the fact that Snow Leopard has moved to .ttf as the preferred font library format over .dfont.
    Office 2008 does not need ANY of its fonts to “run.” However, various features of Office 2008 will be broken or display poorly unless you leave the fonts it installs in place. It’s OK to delete the ones replaced by newer ones installed by Apple.

    Path to Microsoft Fonts: Microsoft installs Office 2008 fonts in a folder named “Microsoft” in the Library/Fonts folder. Your Office 2004 fonts could be in your User’s Library/Fonts folder. For font locations see this page.

    Apple updated some of their fonts for 10.6. These fonts are also installed in the Microsoft folder. The ones in the Microsoft folder are older and should be deleted.
    [Added link: details on removing fonts and font caches]

    • Andale Mono
    • Arial
    • Arial Black
    • Arial Narrow
    • Arial Rounded Bold
    • Brush Script.ttf
    • Comic Sans MS
    • Georgia
    • Impact
    • Tahoma
    • Times New Roman
    • Trebuchet MS
    • Verdana
    • Wingdings 2
    • Wingdings 3
  5. Open Font Book. You’ll notice a yellow “!” next to the ones with duplicates. (You could have other fonts installed by other applications that are duplicates too). Open a window so you can see the Font Book and the Microsoft fonts folder. Delete the font in the Microsoft folder and you’ll see the yellow “!” disappear in Font Book.

    Users are reporting that resolving duplicates didn’t work successfully. I suggest you manually delete the duplicates.

    If that doesn’t work, look at the various Font conflict resolution user tips in these articles:

    Note: I also sorted my fonts by date and found some from way back in 2002. They were not duplicates, but I decided to delete them for good measure. YMMV

    3) Check Contextual Menu Items: Go to ~(yourHome)/Library/Contextual Menu Items and move whatever is there to the desktop. Then do the same with /Library/Contextual Menu Items.This tip was posted by macjack on Apple Discussions.

Note 1: One user reported: “Each time I would delete that plist file it would inexplicably undelete itself! Anyhow, I tried it again; it disappeared.” Seems restarting isn’t the only thing we need to do over and over.

User tips to solve crashing problems.

  • I had a bunch of Datafork TrueType fonts. I removed all of these and suddenly everything worked fine.
  • Some antivirus software is incompatitble (in my case, it made the fonts disappear and I needed to install SL again).
  • I removed Office 2004, restarted the computer (restart is important here) and did a clean installation and updated MS Office 2004 running Microsoft AutoUpdate. It now works!

If you find a tip to share, please leave a comment.

Installing Office 2008 on a clean install of Snow Leopard

Yes, Office 2008 will install and update on a clean install of Leopard. I’ve seen reports were some users were skeptical that Office would install and update on a clean install of Snow Leopard. If you are having trouble it’s not a bug in Snow Leopard, but with YOUR install.

My install of Office 2008 on a clean install of Snow Leopard

I did a clean install of Snow Leopard and selected to install Rosetta. I had an early version of the Office 2008 DVD that installs 12.0.0. If you have a later release that installs 12.1.0 you do not have to install Rosetta to update Office 2008, however you might need Rosetta for other applications. BTW, having Rosetta installed will have no impact on applications that are Universal or Intel-only.More info on Rosetta

After installing from my DVD, the Microsoft AutoUpdater (MAU) automatically popped up asking me to update the Microsoft AutoUpdater. This is a crucial step. The original VISE installer will not recognize any further updates until it’s updated to the package installer.This issue does not affect users with the DVDs that install 12.1.0 (SP1)

Restarting between each update is important. Don’t leave out this step. I suggest you see Restarting your computer after an update is important! for full details. It’s also important to quit all open applications when installing Office. Log out of your User. When you Log in, hold down the Shift key to disable all Login Items. Now run your Updater. (Select to keep the MAU in the Dock so you don’t have to open an Office application to select “Check for Updates” that launches the MAU.

When I launched the MAU to download the 12.1.0 (SP1) updater, it downloaded but did not update. I was still at 12.0.0 after restart. I don’t know if this was specific to my install or if using the MAU download has problems in Snow Leopard.

You can verify the update by checking the Microsoft Component Plugin
Applications/Microsoft Office 2008/Office/MicrosoftComponentPlugin.framework/Versions/12/MicrosoftComponentPlugin

I selected to use the download installer and this time the update was successful.
For the remainder of my updates I selected to download rather than using the MAU to download and install.

[Note added Sept 2010: MSFT has rolled updaters into combo updaters. You only need the 12.1.0 and 12.2.6 updaters currently. Newer DVDs only need the 12.2.6 updater]

Original DVDs of Office come with the installed version 12.0.0.

Install 12.1.0 SP1
Install 12.2.6

Current shipping DVDs will install 12.1.0 (SP1).

Install 12.2.6

EWS Version of Entourage for Exchange support requires 12.2.1 be installed. For full requirements see Entourage 2008, Web Services Edition has launched

Applications ready for Snow Leopard to help with troubleshooting

Additional Info added after published date

Share this:
  • Twitter
  • Facebook
  • del.icio.us
  • Digg
  • StumbleUpon
  • Google Bookmarks
  • PDF
  • Print

93 comments to Troubleshooting Office for Mac with Snow Leopard

  • David

    For Office 2004, the solution I found is to remove the FontCacheTool file from Supported Files folder in Office within the Microsoft Office 2004 folder. That stops word and the rest from doing the check. Removing Do Font did nothing, but this has stopped office from doing its search. So far no problems using word after doing this.

  • Sandymc

    Frankly, I can’t believe this BS.
    Installing 12.0.0 on a clean install of Snow Leopard just doesn’t work. I’ve tried every way – downloading Rosetta (hangs on “deleting existing Office”, disk activity just goes on forever), manually installing the mpkg (appears to work, but see below)
    Then, whichever way you go above, either killing the hanging process, or via the install mpkg route, when you try to install the 12.1 update, you get a “You cannot install Microsoft Office 2008 for Mac 12.1.0 Update on this volume….” error.
    I can understand that these things happen, but for Microsoft to claim that “yes you can install Office 2008 on a clean Snow Leapard install” is just ridiculous.

  • It just doesn’t work for YOU. If it didn’t work, then everyone would not be able to update.
    Did you restart after each install? Did you have all applications quit when installing?

  • Gillian Gallagher

    since upgrading to Snow Leapard, my Entourage calendar entries have duplicated, and when syncing with my iPhone, some of the are triplicated and more.
    Any suggestions?

  • Eoin Stewart

    I’ve tried every step to the letter and Entourage crashes when deleting a message. I’ve found no way around it an have wasted hours on this.
    In closing I would like to say I would very much enjoy kicking someone at Apple’s butt then my own for ever installing Snow Leopard.
    It’s just bells and whistles that are not needed and have fouled up my email.
    Crap.

  • We were all hoping that Sync Services would improve with Snow Leopard, but that has not been the case. You need to only select one items in Entourage Sync Services prefrences to sync at a time. This has worked better. Usually contacts don’t change as often so keep it uncheck then toggle calendcar events off to sync to contacts then toggle calendar events back on.
    You can deal with the duplicates using one of the script listed here: Remove Duplicates
    Tip: If you assign a category to every event, even if it’s a generic category, then if you do get duplicates in the future, all dupes will have the “none” category assigned. You can do this easily using the Calendar custom views to show all events.

  • This sounds like database corruption. Let’s do a couple of tests.
    1) Create a new Identity in Entourage. (drag a few messages from your current Identity to the desktop for testing)
    2) Drag in the test messages to the new Identity. Try to delete.
    If they delete successfully, then this indicates database corruption. If they don’t then we need to test in a new User.
    1) Go to System Preferences –> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching. Test Entourage in a new User there.
    2) If it works, then go back to your regular User and put your “problem” Identity in the Shared folder. Switch back to the new User.
    3) Drag from Shared (it actually copies) and place the Identity in the Microsoft User Data folder > Identities folder. Open and see if you can delete.
    If this works, then it’s a problem in your User’s folder. If it fails then this is another indication that your Identity has problems. It’s possible you have both database corruption and issues with your User.
    If you made a backup of your Leopard install, you can simply revert to your backup.

  • Arthur Carter

    After upgrading to 10.6.1, my Entourage could receive, but not SEND email. After trying most of the suggestions here, I finally removed and re-installed Office 2004. Now Entourage works.

  • Doug Starkey

    Since upgrading to Snow Leopard (OS X 10.6), I have been able to connect to my Exchange 2007 server… but only intermittently. I will show to be connected and be getting emails, and then suddenly, for no apparent reason, I’ll show as being not connected. Sometimes rebooting helps; sometimes quitting Entourage and restarting it helps. Sometimes it just reconnects itself. I’m not getting any errors at the Exchange server that appear to be pertinent (no log-in rejections or anything like that). It’s as if the server decides that I’ve been connected too long and won’t let me back in… or that my connection to the server has gone bad (despite the fact that I can connect to the server in other ways). I was originally running Office:Mac 2004, but have since upgraded to Office:mac 2008 and even installed the Entourage 2008 EWS edition. None of this has helped.
    Any ideas?

  • Try Control-Clicking your Inbox in the folder list and choosing
    Folder Properties > Empty Cache.

  • Stacie

    I installed Snow Leopard on my work computer and have not been able to use any Microsoft Office application since. I have been through all of the troubleshooting listed and it still will not work. If I restart in Safe Mode, the Office apps work fine but I cannot connect to our local server. If I start in normal mode, I can connect to the local server but cannot use Microsoft Office. Please help! I’m to the point to removing Snow Leopard and rebuilding my machine with the old OS.

  • Since rebooting in Safe Mode worked, this indicates problems in your User folder. Have you tested to see if a new User works?
    Go to System Preferences –> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching. Test Office there.
    If it works in the new User, it might be quicker to move your Documents over rather than try and troubleshoot.
    Did you remove the duplicate fonts from the Microsoft fonts folder? Have you tried any of the new Snow Leopard ready utilities like Snow Leopard Cache Cleaner and Font Finagler?
    Have you updated to 10.6.1?

  • Stacie

    Yes, I have created a new user and Microsoft Office still does not work.
    I removed all duplicate fonts from the Microsoft fonts folder and from Font Book. I also updated to 10.6.1.
    I will try the utilities (Cache Cleaner and Font Finagler) to see if they work.

  • If your new User’s account is having problems, you need to look at your Snow Leopard install. You can install Snow Leopard over itself.
    After you do this, re-install Office. Steps to re-install Office

  • cpf

    the problem is the Fax Server. Most of us had the fax server automatically launch at start up…i noticed this when i installed Snow Leopard and a software update popped up asking that in order to use Fax Server, Rosetta had to be installed. The first time i did this. Then i reinstalled Snow Leopard, but skipped this, took Fax Server out of login items, and it works…

  • Stacie

    FINALLY I was able to get my Microsoft Office applications to run on Snow Leopard. This is after calling both Apple and Microsoft and not receiving any answers at all. I moved all of my fonts (Macintosh HD/Library/Fonts) onto our server and deleted the folder from the hard drive. I restarted and moved the fonts back. Two fonts – Lucida and Helvetica – were moved to the trash. Everything works perfectly now.

  • Jeff G

    I have tried most everything outlined on these pages without success. I followed Davids suggestion and removed FontCacheTool and all my Office 2004 apps worked immediately.
    Thanks!

  • Grant J

    Great article.
    Could you perhaps tell us what Font Book is? Is this a new utility found in Snow Leopard? Is it a third party product? If it’s the latter, a link would be useful (and hopefully it doesn’t cost $$ for us on tight budgets). Excuse me if I’m being over cautious, just trying to look before I leap and all that…

  • Font Book is one of the free applications included in your Applications folder. I believe it’s been there since OSX was introduced years ago.

  • Kristian

    I have have also been having trouble with Microsoft Word since upgrading to Snow Leopard. Nothing has frozen up with the fonts, but whenever I try to open up more than one file at a time in Word the program freezes and I eventually have to force quit. I have tried restarting my computer and Word, but after opening up the 1st word document the program freezes if I try to open another.
    Any suggestions?

  • I haven’t seen this reported. Testing in a new User will quickly tell you if the problem is system wide or if it’s your User’s folder that contains the problem.
    Go to System Preferences –> Create a New User in Accounts.
    Place some files in the Shared folder for access in the new User. Switch to the New User by logging out/in or use Fast User Switching. Drag the files from Shared for testing.
    If the problem goes away in the new User, then you know the problem is in your User’s folder. If it continues in the new User, create some new files and test with the new files. Does the problem continue?
    Report your results on the microsoft.public.mac.office.word newsgroup.
    How to subscribe to the newsgroups

  • Jared l rifkin

    Problem: no able to open any Office 2008 appy in snow leopard.
    NONE (not any) of the previous suggestions worked EXCEPT starting in safe mode (shift key)!! but that disabled some normal expectations in use.
    so-
    Problem (at least in my case) was many duplicated fonts in font book. Simply disabling the duplicates did NOT work. TRASHING the duplicates worked and I now have Office fully opening in snow leopard!!

  • Thanks for sharing that trashing rather than disabling fixed the issue. To me, disabling something that has been replaced with a newer version doesn’t make sense in any situation.
    BTW, If you ever have to re-install Office, it will add back the older fonts so you’ll need to remember to delete them again.

  • Fabz

    Thank you so much for sharing this.
    I am running Microsoft Word X on snow leopard and perhaps that may be my problem.
    Personally, I only had issues with “bullets” or “numbering” as they simply won’t print out
    Because of this article I saw that when I created a new user account the bullets printed properly yet, when i went back to the main account, the problem persisted.
    I still don’t know what to do and I am scared that if I upgrade to Office 2008 then i’ll lose everything + I can’t find my old copy of Office X.

  • If Office X works in a new User, you can troubleshoot your current User’s account, but this is often a difficult process if cleaning caches and cleaning up fonts doesn’t fix the issue.
    See Troubleshooting Your User Account for a Problem

  • So I tried everything I found on every forum out there and finally the only thing that worked was this
    Restart while holding down shift to boot into safe mode. From safe mode uninstall office using the MS uninstaller.
    Reboot in safe mode again (hold down shift)
    Install office 2008, then install all of the updates, once the updates are finished reboot before opening anything.
    The only other thing I ran into is i had to rebuild my entourage database once I booted in normal mode. (I have to do this occasionally on my system and the DB is huge 12gig so it is annoying)

  • Could you provide a few more details about your install of Office on Snow Leopard?
    1) Was Office installed prior to upgrading to Snow Leopard?
    2) Was Snow Leopard installed over Leopard?
    3) What problems where you having that caused the re-install?
    4) When you install Office and updated, did you restart between updaters?
    5) What is the original version installed? 12.0.0 or 12.1.0?
    6) Are you running 12.2.0 or v.13 of Entourage?
    7) Were you able to use the MAU to download and install the updaters or did you manually download from Mactopia?
    8) Did you resolve the duplicate fonts after installing?
    Regarding your database being 12 GB.
    1) What type of account? (POP, IMAP, Exchange)
    2) If you export all items as Entourage archive (.rge) file what is the size difference between the .rge file and your database file?

  • Marilyn

    This page was a fantastic help – David’s idea [4 September] of deleting the FontCacheTool has worked perfectly for me – Many thanks

  • Steve Jordan

    I had the same problem with Entourage 2008, a lot of emails were not showing text in email body, it came up blank. This led e to follow a font conflict issue path. After much cleaning and troubleshooting, The solution that worked for me was to disable the “Verdana” font in FontBook.app. Thanks for all the help listed on this page, without I would still be lost.

  • Since installation of Snow Leopard synchronization of Calender to me.com, ICAL and my Iphone hasn’t worked. A lot of events are not synchronized.
    INFO:
    1) Was Office installed prior to upgrading to Snow Leopard? Yes at first – then I tried to remove and reinstall – without solving the problem.
    2) Was Snow Leopard installed over Leopard? Yes
    3) When you install Office and updated, did you restart between updaters? NO
    5) What is the original version installed? It is 12.0.0
    6) Are you running 12.2.0 or v.13 of Entourage? Now 12.2.1
    7) Were you able to use the MAU to download and install the updaters or did you manually download from Mactopia? MAU worked fine
    Hope somebody can help me??

  • I suggest running the Snow Leopard installer over your current Snow Leopard setup. It works like a combo refreshing files.
    If you can verify that the Microsoft Component Plugin is at 12.2.1, then you shouldn’t have to re-install Office, but if you do follow the directions here that explains about restarting between updates. Steps to update Office after installing from DVD
    When you have a complex issue like you have you need to follow the troubleshooting steps:
    1) Testing in a new User will quickly tell you if the problem is system wide or if it’s your User’s folder that contains the problem.
    Go to System Preferences –> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching.
    Test your problem in your new User.
    Be sure to set account to “leave on server” under the Options tab when testing in a new Identity.
    If the re-install of Snow Leopard doesn’t help and you don’t find what’s causing your problems, if you have a drive you can use for setup, I would install Snow Leopard as a clean install then install Office 08 and test.
    Also if you still have a backup of your Leopard install, you should simply revert back.
    Note: it’s highly recommended when updating to Snow Leopard at this early stage that all users have a backup of Leopard so they can revert if they have issues.

  • Steve Kozlen

    Help!!!
    I’ve just installed Snow Leopard and Office 2004 onto my new Macbook Pro. I then down loaded my GMAIL account Inbox data into Entourage successfully but the Sent Items didn’t arrive into Entourage at all. The only data transferred was from Gmail Inbox to Entourage Inbox.
    I also discover that when sending mails from my laptop through Entourage, the message goes out successfully but Entourage keeps no record of the message in ‘Sent Items’. I appear to be losing all the messages I’m sending. They just disappear from Entourage and I can’t find a record of them.
    How can I repair this problem? I want all outgoing messages to be sent to the Sent Items folder.
    Thanks in advance,
    Steve

  • Steve Kozlen

    Here is a second fundamental difficulty I’ve encountered with Entourage 2004 in Snow Leopard.
    I cannot get a secondary POP server e-mail address to work fully. I have entered two accounts into the account settings routine, set my Gmail account as the Default Account and my client’s account for me as the secondary account.
    I am able to receive messages from both accounts, but I can only send messages from the Default Account. When replying to messages arrived from the secondary account, they never leave the Out Box folder and I get a ‘time out’ error message that the server is busy. My client’s serve is not too busy!
    Thanks in advance for your suggestions.
    Steve

  • We aren’t seeing reports from other users with this problem. Have you checked your Rules and MLM rules too see if something needs resetting?
    In addition, verify that your setting in Gmail using your browser are correct.

  • 1. If you can receive but not send then you have a bad SMTP configuration
    2. If you can send but not receive you have a bad POP or IMAP configuration
    You can try re-entering info.
    You can delete account and create a new one.
    Using copy/paste can result in an extra space being added. Type carefully.
    Check your Keychain for corruption.
    Most likely it’s the Advanced settings under SMTP that need to be reset. Everything that worked before you updated to Snow Leopard should continue to work. It’s possible that in your situation, some setting were corrupted and need to be reset.

  • Jordan Melick

    I’ve encountered an interesting glitch with Entourage 2008 v.12.2.1 since installing Snow Leopard. Anytime I go to attach a file to an outgoing email message, the Choose Attachment window that opens to “Select files to attach” always opens to a minimal size. I find myself constantly resizing the window so that I can view files with more information than what is displayed such as, “An…ges Today, 3:40 PM”
    Has anyone else encountered this? Any help would be appreciated.
    Thanks!
    Jordan

  • I haven’t seen this reported. Let’s try to determine where the problem is located.
    1) create a new Identity and see if the problem happens in the new Identity.
    if problem still exists, then go to step 2.
    if no, then the problem is in your current Identity. Make a duplicate in the Finder first as additional backup. A rebuild does make a duplicate, but sometimes in the process the original and backup get merged resulting in total disaster. It’s rare but it happens. Rebuild your database.
    2) Go to System Preferences –> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching. Test the problem in the new User.
    if the problem goes away, then there are issues in your User’s folder.
    If the problem still exists, the problem is with the base OS files and/or Office install. You can re-install Snow Leopard over itself like a combo updater. Try that first. If that fails, you would want to try re-installing Office, but this type of problem generally isn’t fixed by a re-install of Office.
    Let us know what you find.

  • Grant Wiggins

    I have tried 4 different suggestions from 4 different sources (including David Pogue whom I emailed at the NYTime, and Apple) – now, the crashing in Mail, Safari, and all Adobe products has stopped.
    1. Safe start-up, then reboot normally
    2. Fix disk permissions via Disk Utility
    3. Zap the P RAM (Restart holding down option-command P R
    4. Turn filing sharing off then on
    “Anyone that’s getting crashes whenever the system tries to save or open docs should try this:
    -1. Start by opening System Preferences
    -2. Select ‘Sharing’ from the Internet & Wireless section
    -3. From the list on the left choose ‘File Sharing’ and turn it off.
    -4. Delete anything listed in the Shared Folders section
    -5. Turn File Sharing back on
    -6. Log out, then Log back in
    -7. Done!!”
    I was crashing every time I needed to attach something in Mail, make a pdf in InDesign, or download a pdf from a web site. Now, those issues have all stopped. I don’t know which of these 4 did the trick, but it worked.

  • Drew

    I am using Entourage 2008 on my 24″ imac using 10.6.1
    Every time I launch Entourage or Word It just lags – I am then forced to use the force quit.
    I have done a complete uninstall and clean install – same result.
    I have ran disc utility. Still same.
    What seems to be the problem?
    All of my other apps on the computer work fine.

  • Jordan Melick

    Hello Diane,
    I tried your recommended steps “one and two” from above to resolve the shrunken windows when “Selecting files to attach” within Entourage, with no resolution of the problem.
    I had recently installed Rosetta after running OS X 10.6.1 for a couple weeks, which basically reinstalled the complete OS, so wouldn’t that count as a reinstall of the Snow Leopard? At this point my only option would be to reinstall Office ’08 which you’ve indicated usually doesn’t resolve the problem…
    I’ll keep trying all suggestions. Thanks!
    Jordan

  • Installing Rosetta is in no way a reinstall of your system. Rosetta only takes up a few megabytes of drive space, and without it older programs simply won’t run. Rosetta translates most of your PowerPC-based applications to work with your Intel-based Mac.
    Insert the Snow Leopard DVD and install over your current install. Be sure you are updated to 10.6.1 when you finish.
    When you tested in a new User (not a new Identity) did you have the same problem? If yes, then the problem is at the system level. If the problem went away in the new User, the problem is in your User’s account.

  • Did you delete the duplicate fonts mentioned in the article? Have you tested in a new User?

    Go to System Preferences –> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching. Test Office there.

    See the links here for solutions with Office being slow to launch.

  • Kristin

    Hi. Does someone here have running Entourage 2008 and Exchange 2003? After the update on snow leopard I’ve got a problem by importing a certificate from the server (finally we’ve got a new server, too). I asked someone from Apple and they told me that it isn’t possible to import a certificate anymore. Can this be true?
    Thanks in advance for your help
    Kristin

  • Felix

    I asked one of the MVPs that use Exchange and here is their reply:
    I don’t see why it wouldn’t be possible…
    You can find the link for the root cert in the information about the
    certificate itself in Safari. Download it from there and import it in
    your login keychain.
    I did it for a server not long ago and it wasn’t any different from what
    it was in Leopard.

  • Kristin

    Thanks for your answer. The problem ist keychain told me that it isn’t possible to import the certificate (Error 100013). Next thing I will try is to use a .pem certificate instead of a .cer one. (Yeah, and I did that X509Anchors thing, too).
    But the best thing is: the guy from apple finally told me to use parallels :-s
    Kind regards,
    Kristin

  • Eric Pyle

    Greetings to all!
    Your comments have been useful to me in trying to get Office 2008 to work on SL. I have been largely successful, with a few exceptions:
    1. Entourage, Messenger, PowerPoint, and Excel all word, but Word immediately crashes on startup.
    2. None of these work, but hang on startup on an alternative identity
    3. Office 2008 12.1.0 SP1 cannot be loaded – the installer says that it cannot find a correct version of the software.
    I’ve tried reinstalling Office 2008, but the behaviors above repeat.
    Ideas?
    MBP Unibody, 2.53 GHz, 4GB, OS X 10.6.1

  • When you say alternate Identity, are you referring to an Entourage Identity or a new User in System Preferences? Usually a new User has less problems because it’s a clean environment. If Office applications are crashing there then the problem is at the system level. I suspect the failure to update is part of the problem as well as Snow Leopard issues.
    Use “Remove Office”
    Remove receipts. Look in two locations:
    1) Remove all office2008…pkg receipts in /Library/Receipts
    2) Remove the com.microsoft….plist files in this invisible folder:
    In the Finder toolbar under Go, paste in this path:
    /private/var/db/receipts
    Empty the trash.
    Now that you have Office 2008 removed, insert the Snow Leopard installer DVD and install Snow Leopard over your current install. It installs like a combo updater. Be sure you are updated to 10.6.1.
    Run Repair Permissions in Disk Utility.
    Install Office 2008 following the directions here:
    Install Office for Mac 2008
    Steps to update Office after installing from DVD
    Before opening any Office application, you need to delete the font cache files and remove the older versions of Microsoft fonts. Follow the directions here:
    Fonts to delete after installing Snow Leopard
    Verify that you are updated. Verify 12.2.1 update
    All Office applications will show 12.2.0, but the Microsoft Component Plugin is 12.2.1.
    See Dos and Don’ts for a good install to make sure you don’t compromise your install in the future.
    Check List to troubleshoot your install

  • Frank

    Long story; happy ending.
    In Leopard and MS Office 2004, I occasionally had a keyboard freeze, mostly in Excel, but not exclusively. Clicking in a different document would reactivate the keyboard for use in the original app.
    I installed Snow Leopard over Leopard, hoping the problem would go away. It did, in a manner of speaking. After working in Excel for up to an hour, all applications would quit, including the Finder—losing unsaved changes— then Finder would relaunch after about 3-5 seconds.
    I did a clean install of Snow Leopard and re-installed MS Office and other applications. Having read this discussion, I eliminated duplicate fonts and deleted the font cache with no apparent improvement. I removed MS Office 2004 and installed the trial version of Office 2008, which eliminated the problem. However, I was not happy with 2008 as I use a number of Visual Basic macros and don’t have time to learn Applescript to the level needed to replace them anytime soon. I went back and forth a couple of times (what’s the definition of insanity?) and was then ready for desperate measures.
    At some risk, I dug through all the OS folders on my drive and trashed everything that seemed related to Microsoft. Then re-installed Office 2004 (Word, Excel and Powerpoint only). After three days, I am prepared to call the problem solved. I hope this experience helps someone else.

  • Frank

    In my earlier note on Office 2004 in Snow Leopard, I left out an important detail. After the clean install of SL, I restored my User folder, including the Library folder, thus canceling some of the advantage of a clean install. I believe this is what I had to reverse with my trashing of Microsoft related files.

  • Thanks for sharing. BTW, what kind of keyboard?
    The issues with apps quitting is, I believe, a Snow Leopard bug.

  • The link to “thread on Apple Discussions” has an extra character at the end of it causing it not to load correctly on certain browsers.

  • Thanks for letting me know.
    http://discussions.apple.com/thread.jspa?messageID=10093959&#10093959
    You can also find by topic : Altered Font Spacing Crippling for Designers
    Apple.com > Support > Discussions > Mac OS X v10.6 Snow Leopard > Using Mac OS X 10.6 Snow Leopard

  • Maciane

    Hey!
    I’ve been running through this entire troubleshooting but still haven’t been able to fix my problems with Snow Leopard/Office2008. The main problem I have is that certain word files created on my macbook can’t be reopened and that it is impossible to enter notebook mode (have mainly been using word)…
    Any ideas of what could be the problem? Works fine in a new user account but safe mode and reinstall did not help at all…
    /Maciane

  • To get individual help with Word, it’s best to ask on the microsoft.public.mac.office.word newsgroup. For details on subscribing see this article:
    How to get individual help
    You can try these tips that were posted by John McGhie on the microsoft.public.mac.office.word newsgroup:

    Sometimes, the quickest way to resolve this is to simply move over to the
    new User ID and delete the old one. There are a LOT of preferences, and the
    ones that are bad may not belong to Word, or even Microsoft Office!
    You can try this:
    1) Find and drag the file Normal.dotm to your desktop. Unless you have
    moved it, it should be in
    /Users/ ~ /Library/Application Support/Microsoft/Office/User Templates/
    2) If the following files exist, Remove or rename them:
    ~/Library/Preferences/Microsoft/Word Settings (10)
    ~/Library/Preferences/Microsoft/Word Settings (11)
    3) User/Library/Preferences/com.Microsoft.Word.plist
    4) User/Library/Preferences/Microsoft/Office 2008 (the whole folder!)
    5) Then Repair Permissions with Disk Utility.
    No guarantees, but it may resolve the issue…

  • Frank

    Diane asked re my Nov 2 post: What kind of keyboard? It is and was an Apple Keyboard.

  • Jordan Melick

    Hello Diane, I’m back. I finally had a chance to sit down and follow all of your steps with trying to solve the mysterious shrunken window when attaching files to an email in Entourage. (#comment-40718)
    I’ve completely re-installed Snow Leopard and updated to the latest from Apple. I’ve re-installed Office ’08 and rebuilt my database a number of times. All without success.
    I’d be happy to email screen captures to show what is happening, or if you have a debugging application like SoloBug, I could give it a try.
    Ideas?

  • Jordan and I verified off list that this is a “bug” in Entourage 2008 and Snow Leopard. You can workaround this by using Default Folder, third party software.

  • Jason

    Hi I thought I’d ask here since it seems to get some results happening. I was using entourage on my macbookpro version 12.2.3. A few months ago I installed snow leopard and it had no issues, so not sure that SL is the issue
    Last week, entourage just decided to start hanging as soon as it started to download the emails and I’d eventually have to force quit it.
    I’ve tried rebuilding the databases and verifying them, everything comes back fine with that. But it still hangs.
    For now I’ve gone back to using Mail so I can work with my emails, but there is a lot of info and mail groups in entourage that I need to access and have no idea on how to get them.
    Any thoughts would be greatly appreciated.
    Thanx
    Jason

  • This sounds like a problem message trying to download. Use your web browser and log into your account. Move all messages out of the Inbox. You can create a folder to hold these emails. Now try downloading mail in Entourage. Does it improve? If yes, then it’s one of the older messages that is causing the problems. You can bring the messages back in batches to find the culprit.
    If you continue to have problems, troubleshooting is best done on the Entourage newsgroup or the YouTalk list. See this link for how to subscribe: How to get individual help

  • Gerald

    Hi. I have been running Office X on a Mac G5 and a Mac mini under Mac OS 10.4.11 with two separate Office product ID numbers with no problems. I recently upgraded the Mac mini to Snow Leopard and Office X works fine on it, too. However, I can no longer open Office on both computers simultaneously as I could before even though there are still 2 separate product ID numbers. The message I get is “Microsoft Office X cannot start because Microsoft Office is already in use”. Any ideas?

  • This is strange….updating to Snow Leopard should not have caused this problem. Did you re-install Office X?
    FWIW, I haven’t seen this problem reported before so it’s something specific to your setup. I would remove Office X and re-install making sure to use the correct key.

  • John Bennett

    I was having problems with Word in Office V.X, specifically certain fonts would not print and a document would only print up to the point where a bullet was encountered. Both these problems were fixed with your help (THANKS) when I removed all the fonts in the (user)/library/fonts folder. The blog said to remove or rename the fonts folder, but that was not permitted by the system, so I emptied the folder. Rebooted and problem solved.

  • Glad to hear your problems are fixed.
    You can add a folder in the Library folders. For example, Font Disabled can be added and then you can move the fonts into the folder rather than moving to the trash. This can give you some comfort making a change like this. I’ve done this for plugins too.

  • Veceneerponge

    My computer is running slow what steps can I do to fix it?

  • Hollis

    Just got MacBook Pro with Snow Leopard. Entourage keeps giving me a Network Connection failed message, as it tries to dial up to check email! I am connected to a wireless system and have not ever had it set for a dial up. How do I correct this? When I check on the send and receive, then it does get the mail through the wireless connection. How to fix? Thanks.

  • This is more a general question for Snow Leopard. Questions like this are best answered in a forum. We try to concentrate on Entourage and/or Microsoft Office questions here.
    You can check these pages for some help on getting started with your problem.
    Troubleshoot Performance Issues
    Problems from insufficient RAM and free hard disk space
    Mac OS X v10.6 Snow Leopard Discussions

  • jojoleb

    I know that I’m late in the game with this, but I hope this helps…
    I had numerous problems with Office 2008 when I switched over to the mac, until I did the following:
    1. I uninstalled Office 2008 with AppZapper (alternatively you could probably use AppDeleter or AppCleaner, two free apps that basically do the same thing)
    2. Rebooted
    3. Reinstalled Office 2008 from the disc
    4. Ran the update (and it worked)
    I had both the font loading problem and a problem, confused fonts, and was unable to update (the program refused to recognize my hard drive as an authorized place to install the update).
    It seems that you need to purge all memory of Office 2008 and then reinstall it for everything to go back to normal.
    I’m no computer wiz, but the above process did the trick for me. I hope it helps those that are stuck…

  • Ed Waldrup

    Problem:
    We took a newly delivered MacPro, updated Apple software to 10.6.2 and installed Office ‘08. We did not install anything else. Did all Microsoft office updates. Set up an email account in Entourage. Entourage will suddenly drop out with a “Not Connected”.
    Workaround:
    Restarting works as does turning Ethernet off and back on.
    Comment:
    This is not a satisfactory fix for what will be hundreds of Macs.
    Question:
    Are you aware of this Microsoft Entourage 2008 issue with Snow Leopard and do you know of a fix? This is now happening on two (the only two we have now) Macs with Snowy and Entourage 08 latest.
    Any feedback is welcome.
    Thank you in advance.

  • Are these Exchange accounts? This is not a standard complaint so I suspect it’s a setting on your server.
    Do you meet the requirements for the EWS version for Exchange?
    Entourage 2008, Web Services Edition
    You might want to run tcpflow to monitor the traffic. How to use TCPflow to test Send & Receive/a>

  • Ken Gangler

    Ever since installing Snow leopard over leopard, I have had nothing but issues. Itunes won’t sync, and mow Entourage will not work, says there is Data corruption and the files must be rebuilt. Spent three hours on the phone with Apple and they couldn’t fix it. The first few times it worked, not it says there is an error and freezes. People pay extra money for a Mac to avoid these issues and I am disgusted Mac released this program. Can anyone help ? I don’t have the expertise to run through all these steps and I may have to drop it off with Mac for repair.

  • Rick

    While using Office 2004 and 10.6.2, iCal items from Entourage when synced with Entourage are offset by +5 hours. Is there any fix for this?

  • Neva

    Thanks for this, I was going crazy trying to get Office v.X to print to PDF after upgrading my OS. Creating a new user account worked; then I booted in Safe Mode, restarted, and it all works beautifully in my own user account.

  • We have several articles on setting time. Do a search for time in the blog search box.

  • Ed Waldrup

    Diane,
    Reference Entourage 08 giving “not connected” with Snow Leopard.
    We are on exchange ’07 with all updates. I may try to run Wire Shark. We are also troubleshooting with the Apple engineer. Must be something simple as it does not appear to be a common issue I am told.
    Thanks.

  • Are you running the EWS version of Entourage? It sounds like your Exchange client qualifies for v13.
    http://blog.entourage.mvps.org/2009/08/entourage_web_services.html
    Have you tested in a new User? Go to System Preferences –> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching. Test connection.

  • sabin

    Hello Diane,
    I have only just discovered your promising forum.
    I am running office 2004 on a mac book pro (older model) and a newer mac book. on both, the applications crash on right-click or ctr-click.
    In actual fact, this problem occurs on most applications using rosetta.
    i was wondering if you have come across this problem and if there is some specific cure around.
    thank you.

  • Go to System Preferences –> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching. Test your problem in this clean environment.
    If the problems still exist in the new User, it’s a problem with your Office install or your base OS files. If running the Apple combo does not fix, then you might need to re-install Snow Leopard. You can install Snow Leopard over itself like a combo updater.
    Some users have had to re-install applications to get them to work in Snow Leopard. Several Office 2004 users have had to re-install.
    Since you are experiencing the problems in other applications, I would suspect it’s your base OS files. If you have the room to partition your drive, I would do a clean install of Snow Leopard and install all your applications rather than using migration to bring over.

  • Mike

    I have installed Office 2008 on my new Imac with Snow Leopard already installed out of the box but am still experiencing difficulties.
    Has anyone had problems with Office freezing up and requiring you to force quit programs? This happens quite a bit in both word and excel. In word it is particularly problematic with any .doc files.
    Thanks for your help!
    Mike

  • Is Snow Leopard updated to 10.6.2? Is Office 2008 updated to 12.2.3 or v13? Did you remove fonts as described?

  • Shira

    All,
    I have a new iMac (with a wireless keyboard and magic mouse) running Snow Leopard 10.6.3. I’ve tried pretty much everything suggested in previous postings referring to Microsoft Office 2008. At one point yesterday, I think I was able to get a new user account to launch Word, but things are getting hazy at this point (maybe I just think I did). The only thing I haven’t tried is reinstalling Snow Leopard (because I don’t know what that will do to everything else).
    Anyway, at this point I no longer get the “Optimizing font …” message with an endlessly spinning disk on Word; I just get an endlessly spinning disk. When I try launching Excel, the splash screen quickly disappears and a faint bar appears at the top of my screen, but I also just get the endlessly spinning disk. Now here’s where it gets really interesting. When I launch PowerPoint, it starts up right away, and it actually seems to function!
    If someone could help me get Word and PowerPoint to function, I will be so relieved.
    Thanks in advance,
    Shira

  • Alvena Ferreira

    Well, I didn’t do it exactly by the correct instructions but so far things seem to be working fine.
    I first applied all 3 updaters to my Office 2008, did not re-boot between installations, just applied all of them and then re-booted.
    After that my MS Word was still fraught with crashing problems, and in searching for help, I came upon this page.
    I then opened Font Book and found the duplicates.
    It took a while for me to locate the system fonts, but I finally found them. (My fonts were not in my user library, but instead they were in the main system library.)
    I located the MS Office fonts, placed that window next to my opened Font Book, trashed all of the duplicates, re-booted, emptied the trash, and opened Word, and so far it’s been fine.
    Thanks again for the font removal tips, I seem to recall years ago having to do this with a prior version of Office, maybe Office 98.

  • Blavo

    Like Neva I wasn’t able to save Word X documents to PDF. Following on from Neva (Jan 27) and Diane Ross (Feb 13) I found I could save Word X documents to PDF under a newly created user id. But I think this is because the new user got a refreshed set of document defaults (probably the Word X default defaults). After some experimentation I found I could save documents to PDF under my original user id provided I didn’t use Times New Roman font (I substituted Times) and I didn’t use any Word bullet points (I made my own manually). No doubt there will be other things that I don’t use that will cause the problem.
    The way I found these two problem areas was to make, under my original user id, a very simple new document that would save to PDF (based on a document made under the new user id). Then I copied and pasted the content of the original document (that wouldn’t save to PDF) into the new document, piece by piece. After each piece I tried saving to PDF. By trial and error I was able to identify the things that prevented saving to PDF.
    Fine for me since I have the absolute minimum number of documents in Word. But probably not that helpful for those that have embraced Word on the Mac.

  • Alvena Ferreira

    One thing I found in my work: I had copy-pasted some text snippets that I use frequently in Word, into a program called Drop Drawers–this was done PRIOR to purging my system of the duplicate fonts. After having removed the duplicate fonts, I tried pasting some of the Drop Drawers text snippets into Word docs and Word crashed every time. I finally realized that the text clips in Drop Drawers had probably been made with the duplicate fonts that I had removed. I subsequently replaced those text clips with fresh clips made after the purge, and everything has worked fine since then.
    Perhaps some other users are having ongoing issues with inappropriate word behavior related to residual pieces of texts that were made with the old duplicate system fonts.

  • Try deleting font caches before replacing items. This would be a quicker solution.

  • Ed Waldrup

    Diane my previous issue of January 7 was caused by Casper. That got fixed.
    Now having and intermittent Snow Leopard issue with Entourage and OWA at the same time. Exchange server 2007. Mac OS 10.6.4. Entourage Client is 12.2.5.
    New Mac Book Pro intermittently dropping Entourage and Outlook Web access on ethernet and wireless. This happens in a New York office with an Airport Extreme (firmware version 5.7). Funny thing is that that computer runs fine with Entourage etc. at the users home or anywhere else but that office. No one else in the office has issues. They are on Leopard.
    Those two programs, Entourage and (OWA on Safari or Firefox) are the only two affected. If you just click the button for OWA nothing happens. It may work fine for hours and then suddenly drop. Deleting and re-adding ethernet and wireless works for a while. We had her ship it to Dallas and while it was here for a day it never hiccupped on wireless, ethernet, the AT&T card or DSL.
    Any thoughts?
    Thanks,
    Ed

  • I’m assuming you have Snow Leopard updated to 10.6.4. Has the Airport Extreme been eliminated from the mix? Even if others are using it, it could be her physical location.
    The Exchange Admin forums on TechNet might be a source to get some help:
    http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/threads

  • John Palmer

    Brilliant. Sorted out a pesky printing problem for my elderly Office v.X under Snow Leopard. Many many thanks

  • Linda Babstock

    I just purchased a new Mac that came with Snow Leopard installed. I installed my Microsoft Office 2008 without difficulty, except that I can no longer insert a picture in outgoing emails. Does anyone have a solution to this?

  • Make sure you have HTML selected to insert a photo into the body of a message.

  • Ken Plitt

    New iMac 21.5/3.06 GHz/1TB drive/4 GB RAM with Snow Leopard 10.6.4 factory installed. Having trouble previewing & printing some – but not all – Word docs I receive as email attachments, even though I can print the same documents without problem via my MacBook Pro (OS 10.5.8) using shared HP printer. I can open and view the documents just fine but print operation yields only a single, blank sheet of paper. Office 2008 installed on both computers and documents transferred from my old G5 print fine so I’m questioning if this is a Snow Leopard-Word-Mail compatibility issue?
    Only other clue is attachments opened on iMac have an odd file name that differs from same .doc or .docx name opened on laptop (a “#13XXX” type pattern of letters and numbers appears inserted in the filename). Doing a “save as” and renaming the file doesn’t seem to solve the printing problem nor can I create a .pdf version of the file.
    Any suggestions?

  • Make sure your printer drivers are up to date on the new computer. Next run Font Book and clear up duplicate fonts and delete font caches.
    Microsoft fonts to delete after installing Snow Leopard
    (includes help deleting font caches)

  • After upgrading to Exchange 2010 and Entourage EWS some of our users aren’t able to receive emails on time.
    For example: When someone sends the user the email, email shows up on OWA and iPhone fine but is an hour or two hours late in Entourage.
    I’ve tried new identity, new user account and even tried a brand new MAC and samething. I cleaned up the mailbox and also cleaned up calendar items and samething.
    I NEED HELP!